Ich kann mich nicht mehr ins TYPO3 einloggen…

… so lautet eine Fehlerbeschreibung, die mich in den letzten Tagen erreicht hat. Der Login Versuch produzierte tatsächlich eine Fehlermeldung.

#1195126772: $toolbarItem "shortcuts" must implement interface backend_toolbarItem
#1195126772: $toolbarItem „shortcuts“ must implement interface backend_toolbarItem

Was war passiert?

Meine Recherche hat ergeben, dass der Hoster die PHP Version aktualisiert hat. Die eingesetzte TYPO3 Version unterstützt die aktuelle PHP Version 5.6 nicht.

Die PHP Version wurde aktualisiert, da die vorherige Version schon seit längerer Zeit keine Sicherheitsupdates erhalten hat. Um den sicheren Betrieb einer Webseite zu gewährleisten ist es notwendig regelmäßig Updates einzuspielen. Das hat der Hoster an dieser Stelle getan. Die TYPO3 Version war nur leider nicht mit der neuen PHP Version kompatibel.

Die Lösung

In diesem Fall war die Lösung eine recht einfach, durch das Update der TYPO3 Version auf die Version der 4.5.40 LTS wurde das Problem behoben. Natürlich nur vorerst, da auch die Version 4.5.40 bereits seit mehr als einem Jahr nicht mehr mit Updates versorgt wurde.

Diese Lösung sollte natürlich nur eine vorübergehende Lösung darstellen. Ein Update auf eine aktiv mit Updates versorgte Version von TYPO3 sollte schnellstmöglich erfolgen, da nur eine aktiv mit Sicherheitsupdates versorgte Seite vor Hackern schützt.

Kontakt

Bist du von dem Problem betroffen und benötigst Hilfe bei dem Update? Melde dich einfach unkompliziert per E-Mail an typo3@stephan-meier.com oder alternativ per Telefon unter 021619909701 bei mir.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.